Working with files in Legacy

Things you need to know about files to use Legacy:

* how to create a new Family

* how to choose a Family work with
* how to import a Family

* how to export a Family

* how to maintain Family files

* how to compare Families

* how to merge Families

* how to manage media

Creating a new family

Legacy groups its files into Family Files. The first one you encounter when you start using
Legacy is the Sample family file. You have, since then, added your own file to collect your
own data. If you are like me, you have several family files, one for your mother's line, one for
your father's line, one for your spouse's line, etc.
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Click on the File tab, then on New File

o X
' What would you like to do?

Please select one of the following choices:

As you can see, there are several options as to how to

create a new Family. Those options are discussed in the

ek ke et rest of this document. To create a new Family database,
< click the first button and follow the instructions.

Anns

Other Choices:
( Start a New Family File. ]

Choose a Legacy Fie to Open ]

(
( import From Another Program... [ Open the SAMPLE fie )

(__Download my famiy trom Famiysearch |

View the "What's New" help topic
View the "Getting Started” help topic

To learn more about what Legacy can do for you, watch the Wateh Legacy Tour
video. (Requires Internet access.)
Exit Setup



Choosing a Family to work with

When you start up the Legacy software, it will display the family file you last worked with, but
you have the option to go to any one of the families you have created.
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Click on the File tab, then the Open File icon
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Unless you have hopelessly lost your Click on the family you want to work on

family, click on Select the file

Importing a Family

If someone has sent you a Family file to get started with, they will tell you what format that file
is in. Usually, the file will be a GEDCOM file, but sometimes it will be another format.
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Click on the File tab, then on Import then choose the file format of the Famzly you want to
import. If you have trouble, choose the Import Wizard.



Exporting a Family

You export a Family by creating a file and sending it, via email or Dropbox or flash drive or
whatever means you have.

You can export
* an entire Family,

» parts of that family. For example, you might just want to export the direct descendants
of a specific individual. Tag those individuals using the tagging facility of Legacy. That
is a topic of another discussion.

Once you have chosen the part of your Family you would like to export, you can export
» to another Legacy user by exporting a Legacy set of files.

* to someone not using Legacy by exporting a GEDCOM file

Creating a GEDCOM file
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Click on the File tab, then on Export. Choose the GEDCOM option

The safe choice on file formats is the

@ GEDCOM Export

u] X |
. GEDCOM Export | GEDCOM 5.5.1 format, as defined by
[ options LDS and which has been in use for many
Type of Fie to Produce F"::‘;"""‘ |
Produce file for: | GEDCOM 5.5.1 Only i Ei:;::'r yearS.
Character Set: | UTF-8 Ml
Break Note fines every: 60 | characters (at nearest word) UFT 8 IS a COdIng SyStem that aIIOWS for
B the greatest variety of symbols, and
Eern J yOrsy
T s should cover any kind of comments you
[Jinclude general To-Do items . .
[ vt S sy et s st might have in your database.
[ show double dates.
The options on the right are important,
especially the Privacy Options. Click on
I Record Selection. ” All Records in the Entire Family File ‘
those buttons and follow instructions
[ (emse ]

Set the options, then click on Record Selections or All  Leave the rest of the options unless they
Records. Wait for file creation to complete. mean something to you.



Maintaining files

Backing up your files
o | You should do this early, do it often. A lot of effort

' Backup Joes into finding and collecting genealogical data.

Which files do you want to backup? You really don't want to have to repeat that effort!

[] Data Files

e The default location is on your C drive, but it is
Research Guidance results file

I Ecte— much better to back up to an external disk drive or,
Clipboard files (To-do, source, etc.)
i s O sckmg better yet, to the cloud.

| | T ——— Iy you have collected media, don't forget to back

l Currentt C\U::rs\ﬁmn\Dm:nments\LegnDy Family Tree\Data\Sample 2015-08-27 10.14.32 |

i - that up as well.

[[] Media Files .
[ I — ] The options button allows you to add dates to the
Currently: ﬁ:n\rL:ie;\::|n;l3}ucnments\\.egncyFamuryTree\Deta\Sample—medla2015—03—27 ‘ name Of your backup files’ WhiCh Would help you
| Backup " Options.. l[ Cancel ][ Help } keep traCk Of them.

You need to decide how and when to weed out backup files. They take up space, but that
isn't as important as it once was.

File Maintenance

—e— Each of the maintenance selections starts

Check/Repair Family File
with a warning that you are about to
- Check/Repair Family File | change your master files. Keep going to
: g I’n:;r:::-;l:kt‘npp;;;:r:e:;:eyr::i:tre;n;net;e operation on your Family File. tis a good idea | see what your options are. But read the
: option box before you proceed!

Show this message before each File Maintenance operation

Proceed | [ Cancel ] { Help
Check/Repair
0 Check/Repair Family File: C\Users\Ann\Documents\Legacy Family Tree\Data.. X RemOVi ng Deleted Records
- Check/Repair Family File When individuals are
All deleted records are automatically removed from the data files and an integrity check of al deleted from the Famlly

information is performed. This may take a while depending on the size of your family file.

WARNING: Do not stop this process or close Legacy. Even if your computer appears to be Flle, a” references to them
e e e e are removed but the

individual's information still
exists in the file. To
remove the information,
making the room available
for other additions, select this option. Legacy will go through the file and

l Proceed | [ Cancel ] [ Help ]




compress out all records that are not referenced. It also checks all data integrity

within the Family File.

Sort Events and Facts

You can have Legacy sort all of your individual and marriage events and facts
into date order while the Check and Repair is being done by selecting the Sort

all events by date option.

Integrity Check

Legacy runs through your family file and checks the integrity of all the links to
ensure that there are no pointers to deleted records.

Error Log

All actions taken during the verifying process are recorded in a text file named
ERROR.LOG in the [My Documents]\Legacy Family Tree\ AppData\Log folder.
This file can be viewed with any text editor or word processor.

List Cleanup

o Master Lists Cleanup Family File: C:\Users\Ann\Documents\Legacy Family Tree\Data\Sample.fdb X

- Master Lists Cleanup

Remove Abandoned Information from Combine Duplicate Entries for

‘Surnames: ] surnames

1

[] Locations Locations

[] sources Sources

: Source types Source types

[] Event definitions Mailing addresses

[] Marriage statuses Event addresses

[ "] child statuses Repository Addresses
[] Mailing addresses ] To-Do Categories

; Event addresses To-Do Localities

L Repository Addresses Media file locations

| To-Do Categories

[]To-0o Locattes ( SetAl ] | Clearal |

Child-parent relationships E| Ignore case
(Wa and WA would be combined.)

Keep/Restore Original Values for
Source types

Event Definitions

Marriage statuses

Child statuses

To-Do Categories

Child-parent relationships m

[ erocees | I Cancel ] [ Help ]

You can clean up as many lists as you want

Remove Abandoned
Information

You can have unused entries
removed from any or all of the
master lists maintained by
Legacy. For example,
abandoned entries can happen
in the Surname List if you were
to delete all the people with a
certain surname from the family
file. That surname would still
remain in the master list as an
unreferenced name. You can
have Legacy run through the
Surname List to remove any
names that are not being

pointed to. This is most often the case if you entered a misspelled name and then later
corrected it. "Smiht" could end up in the list, taking up room, and never be referenced.

To remove abandoned information from lists:
1. Select the lists you want to clean up by clicking on the checkbox next



to each list name. (You can select all the lists by clicking Set All.)

Keep/Restore Original Values

Legacy starts with a few built-in lists. These include common Source Types,
Event Definitions, Marriage Statuses, Child Statuses, To-Do Categories, and
Temple Names. When purging unused items from master lists, you may want to
keep the original default entries even though they have not been used yet.

Combining Duplicate Entries

While cleaning up the master lists in your family file you can have any duplicate
entries combined into one. This does not mean duplicate individuals; it means
duplicate sources, locations, etc.

Compact Family File
When individuals are deleted from the family file, all references to them are
removed but the individual's information still exists in the file. To remove the
information, select this option. Legacy goes through the file and compresses out
all records that are not referenced, making your family file smaller.

Comparing Families
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Click on Tools, then Campare Two Files

This tool will take you to the Duplicates routine, but instead of checking for duplicates within a
family, it will check for duplicates between the file you are currently viewing and another you
choose from your list of Families. As you find duplicates, you will be given the option to tag
them in either file or in both.

Since you initiated the Compare Files routine, you should have some idea of what you want to
do with the tagged individuals.



Merging families (Split Screen View)

You can have several families, each with its own set of files. Normally, you work on them one
at a time, but it is also possible to show them side by side to drag and drop individuals from
one to the other. If you do this, Legacy will check to see if you are creating possible
duplicates.
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Click on View then on Split Screen
= S, = Here you have the option of looking at
- Question o two different parts of the file you
0 Do you want to open a different Family File in the new window? were Working on or

o two different family files.

Follow the directions for each choice.

Now you work with one file at a time, but you can see both of them. The active file is the
highlighted one. Navigate in this file as you would if there were only one file.

If you are comparing two different files, and you intend to follow the directions below, be sure
to back up your files before you begin!

ht oI you are comparing two different files, you are
- Copy Between Family Files ||y to find an individual in one file that you
e i P want to add to the other. With both files
S - showing the family view, click on the individual

—— — | you want to copy over, then drag him over to

’ pomate N vt ] the second file. The copy will not happen at
u;‘“‘ ; 1 that time. Instead you will be shown the Copy
g 1 ' Between Family Files screen.

[ Exclude LDS nformation [AFil all existing abandoned RINs/MRINs

[ Suppress details for iiving peopie
[ change name to "Living”

Copy Private individuals |
[]'Show Combine options when event definitions o locations are different START COPY

T |
[ Pause ] [ AutoSource... -] f Cancel 1 [ Help |




Pay attention to these statistics. If you have chosen

' S the wrong options above, this will be your first clue.
mport ComPIete it it doesn't look right, you can choose the Undo

e Import from the Tools tab of the Ribbon Bar
Lowest RIN during import: 210
| Individuals:2
Families: 1
Sources: 26
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To undo an import, click on the Tools tab, then on Undo Import

After you press OK, Legacy will take you to the Duplicates routine, to discover any overlaps
between the two files. This is a topic for another document.

To go back to a single file view, click on the x in the righthand corner of the file you want to
close.

Managing media

If you are like me, you tend to move files around. For example, | just moved all my photos to
Dropbox. And guess what...Legacy couldn't find them anymore! Legacy can help.
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Click on Tools then on Media Relinker

e @ Media Relinker
View File?

' View File? - Relink Media

7//Ilelink My Media [ Gather My Media Files |

X

45 media files are missing. Would you like o view the Missing Media List in your text editor?
Q If you have pictures and other media files that need to be found and relinked to the

individuals in your family file because of importing, moving to a new computer,
moving your media files to a new location, etc., Legacy can do it all for you. Just
click the Relink My Media button

Click on Yes to get a list of missing T o 4 vk e e B e
media

Relink My Media

] Unlink missing media files
[ Make a list of all missing media fies Drives to Search
[0 Also search for fiies in Windows system folders (try this if your fies are not found anywhere eise)

I L=l

[
Click on Relink my Media to have Legacy find the files



You can optionally use the list to chase down and attach the missing files yourself.
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On the left is a list of all the individuals in your family file. In the middle is a list of the pictures
on your computer in the file you have pointed to. Click on the Attached Pics tab on the right to
see the highlighted picture.

To attach a particular picture to a specific individual:

1. Highlight the individual in the left window.

2. Find and highlight the desired picture in the upper-center window.

3. Click the Attach button near the lower-right corner. This will add the picture to the
individual's picture list.
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